Symptom
Your requirement is to update the status of the Phone Call activity from Open to In Process using Data Workbench, but you are not able to proceed due to Processing Error:
Process type can't be changed
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Login to the HTML5 client
- Go to Data Workbench workcenter
- Go to Export tab
- In the Search field, select the object Phone Call
- Select Data
- Select field
- Select Next
- Export Data
- Go to the Monitor tab
- Download the exported file
- Update the field Status with value 2 and field Status Text with In Process
To Upload the file:
- Login to the HTML5 client
- Go to Data Workbench workcenter
- Go to the Update tab
- Select the object Phone Call
- Select Next and Browse for the file
- Select Upload
- Choose Next
- Select Update
- In the Monitor tab, check for the respective Task ID
- The records in the file have the Processing Error
Cause
The update is failing as some of the leading zeros of Code values are truncated while updating the CSV file.
Example:
DocumentType should be 0002 instead of 2.
Resolution
You may follow the below steps in the system:
- Use the Notepad++ to edit your CSV file
- Save the exported CSV file on your system
- Right Click on the CSV file and select Edit with Notepad++
- Make the changes to the Status and StatusText fields
- Select Encoding and Select Convert UTF-8
- Save the file on Menu->File->Save as
- Provide a name for the file and add the extension .CSV for example: filename.csv
- Upload this file in Data Workbench
Now check the Activities workcenter for the respective Phone Call Activity to understand if the Status is updated.
Note:
You may use software which is approved by your organization/IT.
Further, refer section 1.2 from Data Workbench User Guide on guidelines to update CSV files.
Keywords
Data Workbench User Guide, leading zeros, leading zeroes, zero, Value truncated , KBA , data workbench user guide , leading zeros , leading zeroes , zero , value truncated , LOD-LE-AM , Activity Management , How To