Symptom
The Customer runs a query to fetch details from any one of the RCM Entities and it is taking Much longer time to fetch the details.
Environment
SuccessFactors Bizx - Recruiting
Cause
System behavior with respect to the Query the customer executes, if the entity has more number of Custom fields
Resolution
For Eg , the customer runs the query
https://salesdemo4.successfactors.com/odata/v2/JobRequisition?$top=30&$expand=jobApplications
Where it is expected to fetch the first 30 entities from the instance and this will take longer time if the Application/jobrequisition has more number of custom fields.
The query is expected to parse the value for the custom field as well and will fetch it back. This will take moretime when compared to Standard fields.
It is always advised to optimize the query only to select the field you would like to fetch , instead of all the fields
Something similar to this "https://salesdemo4.successfactors.com/odata/v2/JobRequisition?$top=30&$format=json&$expand=jobApplications&$select=jobApplications/applicationId".
Keywords
KBA , LOD-SF-RCM-API , Webservices & APIs , Problem