Symptom
- Error: 'Failed to process the job application' from career portal.
- ERROR [FBJobApplication] Failed to process the Job application
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Access the external career site
- Select a job requisition and try to apply
- Error 'Failed to process the job application' will occur
Cause
There could be a few potential causes for this error. These are the ones we have identified so far:
- Missing Rating Scale Description
- Country Picklist Misconfigured on the Candidate Profile Template
- The Job Requisition and Job Application Template have not been linked
- RMK switch has been enabled but there is no further configuration completed
- If RMK and CSB are enabled, check that the brands are configured properly in CSB with correct microsite IDs
- An email was sent to the candidate with the application URL, and the applicant ID in the URL is not linked to the candidate opening it
- Resume Parsing is enabled, and Candidate Standardization Mapping is not configured
Resolution
- Missing Rating Scale Description
- Select the affected job requisition
- Open the job details from the instance and select the 'Rating Scale'
- Ensure the rating scale description has been populated and save
- Country Picklist Misconfigured on the Candidate Profile Template
Please ensure that the country picklist on the CPT is configured with the correct field type.
- The Job Requisition and Job Application Template have not been linked
Make sure the connection has been made between the two templates in the Job Requisition template. For example:
- RMK switch has been enabled but there is no further configuration completed
Please either finish the RMK set up or disable the switch if not required.
- If RMK and CSB are enabled, check that the brands are configured properly in CSB with correct microsite IDs
Please ensure that a microsite ID is associated to each brand created in CSB.
- An email was sent to the candidate with the application URL, and the applicant ID in the URL is not linked to the candidate opening it
When sending an email to the candidate, make sure to use the standard application URL token in the email so that the token renders with the application ID correctly linked to the candidate.
- Resume Parsing is enabled, and Candidate Standardization Mapping is not configured
As part of the process required to map the fields by using Resume Parsing, the Candidate Standardization Mapping needs to be configured. Otherwise, the fields don't get mapped.
See Also
Keywords
rmk, csb, site, career, careers, candidate, applicant, app, appId, error, edit, application. , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem