SAP Knowledge Base Article - Public

2469253 - Business Rule Workflow Trigger for Home Address Changes Only

Symptom

How to create a Business Rule Workflow Trigger for Home Address Changes Only

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Employee Central

Reproducing the Issue

Desired Results of Rule

  1. Edit Home Address Type Field Only
  2. Trigger Workflow
  3. Edit and other Address Type field for example Mailing
  4. No Workflow is triggered

Cause

This can be achieved using a Simple Model Based Object Business Rule.

Resolution

Set up the Business Rule as Follows.
Please Utilize the Address Model base Object and add all field which you would like to trigger the workflow to the "Or" conditions of the rule:

Important: We recommend that you use the Trigger Workflows scenario while creating new rules instead of the Basic scenario. This special-purpose business rule scenario Trigger Workflows, helps to create rules more easily because it provides useful guidance at various steps.

Trigger Workflows

  • You can use this scenario to create rules that trigger workflows to approve data changes. In Manage Business Configuration, rules created using this scenario can be registered only for the onSave event type.
  • Since Release 1911 - Rule Scenario Base Objects Used in Workflows Triggering Rules for Employee Central Data Objects - Trigger Workflows

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This rule should be triggered on the homeAddress Element or on each country/region-specific element if you would like a country/region-specific Configuration.

If after creating the above rule you find the Workflow is triggering for all Address Types.
Please check that on the either the country/region-specific Home Address Element or the Parent Home Address Element that you are not triggering a second, differently configured Business Rule.

NOTE:

  • The if condition checks, for changes to the fields value compared to previous value are required for this rule to work only for the specified address type. 
    These if conditions should be added under a Parent Or condition as seen in the above workflow.
    Please note that only 4 fields are checked in this example, but you will need to add this condition for each field you would like to check in the workflow consideration. 

  • This configuration will not work when using XML Event Reason Derivation so you must have Enabled Business Rules for Workflow Derivation in order for this workflow to trigger.

 

FAQ - Additional Information

Q) Where can I get information on this from the Guide?

A) Guide:Implementing and Managing Workflows                                                                                                                             Chapter:Triggering Workflows with Business Rules

See Also

  • 2469253 - Business Rule Workflow Trigger for Home Address Changes Only
  • 3468733 - Diagnostic Tool for Employee Central save transactions and workflows
  • 2472648 - Using the Check Tool to Check a SuccessFactors Configuration
  • 3408436 - How to find the workflow is triggered by which business rule from workflow details page?
  • 2092849 - How to create a Business Rule to validate data on change/save, and provide a Warning or Error message
  • 2632631 - How to Raise an Info Message on Position Change
  • 2437420 - Which Portlets Support Cross Portlet Business Rules
  • 2163077 - Business Rules Base Objects issue
  • 2257064 - Employee Central - Business Rule Execution Log

Keywords

Business Rules for Workflow Derivation, Home Address Type, Workflow, warning, message, on change, on save, rule, Trigger Workflows   , KBA , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , LOD-SF-EC-WFL-RUT , Workflow Routing, Dynamic Roles & Groups , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions