Symptom
You are replicating contacts from ERP/CRM/S4H to C4C using the Business Partner replication. The replication goes fine without errors, but the contacts are not visible in C4C.
Also, you noticed the business partners are available under Business Partners view, but they do not have the Contact Person role.
Reproducing the Issue
- Go to Customers work center and select Contacts view.
The contacts replicated are not available.
Cause
The field RoleCode is missing in the payload of business partners affected.
For this reason, the business partner is not created as contact person.
Resolution
Send the field RoleCode with value BUP001 which corresponds to contact person in your payload
Example:
-<Role actionCode="04">
<RoleCode>BUP001</RoleCode>
-<ValidityPeriod>
<StartDate>2017-05-02</StartDate>
<EndDate>9999-12-31</EndDate>
</ValidityPeriod>
</Role>
Keywords
KBA , LOD-CRM-ACC , Account , How To