Symptom
- User has reminder notices that have already been completed. How do we get rid of the reminder notices?
- Only 50 notifications are showing in the bell icon.
- The notification configuration settings were switched off but to-dos gets "stalled" so they can´t be cleared.
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Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Log in and you will see the bell icon in the header.
- Click on it to view the notifications.
- See that there are old notifications appearing.
Cause
- The number of bell icon notifications can't be empty due to the current design.
- The notification panel can only list at most 50 latest notifications and only the new notifications within the 50 latest notification can be viewed.
- The number of new notifications will be appear in the notification bell icon.
- This design could cause the bell icon number always show numbers due to some notifications which were pending and have now been replaced in the notification pop up panel by a more recent notification.
- As the maximum number of notifications that appear in the notification pop up panel is 50, it is impossible to see or complete the pending notification.
- After notifications are switched off, the system will prevent sending new notification but existing ones will remain in the system until expired.
Resolution
- There is a weekly recurring notification purge job which will remove 30 days old notifications automatically.
- By default the job removes 1,000,000 notifications per week.
- If the number of notifications of your instance is greater than 1,000,000 it is expected that you will continue seeing some old notifications in the bell icon.
- You can change this number number of purged notifications to up to 50,000,000 notifications being removed per week, please contact your Partner or Customer Support to request this change.
- If the number is much bigger than 10,000,000, please contact your Partner or Customer Support requesting the execution of this job more frequently to clear the queue faster.
- It is an expected behavior that the system does not purge existing notification after switching off related configuration so existing ones will keep in the system until expired. A possible workaround is to run "Notification Purge" Job which purges the notification by time range as mentioned above.
Customer Action: As a customer, you don't have access to Provisioning. To complete tasks in Provisioning, contact your implementation partner. If you're no longer working with an implementation partner, contact SAP Cloud Support.
- Customer must provide a written approval for above task (Create Job Type: Notification Purge)
Note for Partner or SAP Support:
- The job can be setup as a scheduled job from Provisioning
- Job Type is "Notification Purge"
- Generally setup to run once a week with a setting of 1,000,000 notifications to be purged - but this can be increased up to 50,000,000 notifications to be purged on each run.
Example: Job Type: Notification Purge
Job Parameters:
- Number of notifications to purge (1 - 50,000,000):
- Number of days after which notifications are purged (enter a number other than 180):
FAQ - Additional Information
Q) Where can I get information on this from the Guide?
A) Guide:- - Chapter Notifications
See Also
Keywords
Notifications, Bell Icon, Notification Purge, clean , KBA , LOD-SF-PLT-NOT , Email Notifications , LOD-SF-EC-ALR , Alerts & Notifications (saveAlert - EC Core only) , Problem