Symptom
- User has reminder notices that have already been completed. How do we get rid of the reminder notices?
- Only 50 notifications are showing in the bell icon.
- The notification configuration settings were switched off but to-dos gets "stalled" so they can´t be cleared.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Log in and you will see the bell icon in the header.
- Click on it to view the notifications.
- See that there are old notifications appearing.
Cause
- The number of bell icon notifications can't be empty is due to our current design.
- The notification panel can only listed at most 50 latest notifications and only the new notifications within the 50 latest notification can be set as viewed by customer.
- The number of new notifications will be appear in the notification bell icon.
- This design could cause the bell icon number always show numbers due to some notifications which were pending and have now been replaced in the notification pop up panel a more recent notification.
- As the maximum number of notifications that appear in the notification pop up panel is 50 it is impossible to see or complete the pending notification.
- After notifications are switched off, system will prevent send new notification but existing ones will remain in the system until expired.
Resolution
- We have a weekly recurring notification purge job which will remove 30 days old notifications automatically.
- By default the job removes 1,000,000 notifications per week.
- If the number of notifications of your instance is greater than 1,000,000 it is expected that you continue seeing some old notifications in the bell icon.
- You can change this number number of purged notifications to up to 50,000,000 notifications being clean per week, please contact your Partner or Customer Support to request this change.
- If the number is much bigger than 10,000,000, please contact your Partner or Customer Support requesting the execution of this job more frequently to clear the queue faster.
- It is an expected behavior that do not purge existing notification after switch off related configuration so existing ones will keep in the system until expired. A possible workaround is to run "Notification Purge" Job which purge the notification by time range as mentioned above.
Note for Partner or SAP Support:
- The job can be setup as a scheduled job from Provisioning
- Job Type is "Notification Purge"
- Generally setup to run once a week with a setting of 1,000,000 notifications to be purged - but this can be increased up to 50,000,000 notifications to be purged on each run.
See Also
Keywords
Notifications, Bell Icon, Notification Purge, clean , KBA , LOD-SF-PLT-NOT , Email Notifications , Problem
Product
SAP SuccessFactors HCM Suite all versions