Symptom
User receives error "You do not have permission to download this file" when trying to view the results of an import via monitor jobs.
Reproducing the Issue
1 – Navigate to the ‘Monitor Jobs’ page.
2 – Select ‘Download Status’ of any job.
3 – Open the downloaded excel sheet. An error "You do not have permission to download this file" appears.
Cause
This error is due to user permissions meaning the impacted user cannot access the file/s.
Previously, when an Admin imported Employee Objects and Foundation Objects, the status of all imports could be monitored by other Admins as well.
With this release,the system by default restricts the Admins to view the jobs that are performed by others.
To enable Admins to view all the jobs, the Allow users to view all the jobs. (By Disabling this option, users can view only their job status.) option must be enabled from Admin Center Manage Permission Roles Permissions Administrator Permissions Manage User .
Resolution
To enable Admins to view all the jobs, the Allow users to view all the jobs. (By Disabling this option, users can view only their job status.) option must be enabled from Admin Center Manage Permission Roles Permissions Administrator Permissions Manage User .
1 – In Admin centre, navigate to ‘Set User Permissions’ and select ‘Manage permission roles’.
2 – Select the System Administrator role and hit the ‘Permission…’ button.
3 – Navigate to ‘Manage User’ under the ‘Administrator Permissions’ header.
4 – Tick ‘Allow users to view all the jobs’:
See Also
ECT-63153
Keywords
Job Response Permission Monitor Jobs , KBA , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Problem