Symptom
You are trying to reverse the invoicing of a Customer Project. You have canceled the Customer Project Invoice Request and the Customer Invoice is still Released at this stage.
In the Invoice Request view of Customer Invoicing work center, the Customer Project Invoice Request's status is With Conflict.
You wish to correct this status before canceling the Customer Invoice.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing Work Center.
- Navigate to the Invoice Requests View.
- Select the Option All Invoice Requests.
- Find Customer Project Invoice Request ID, then you can see the Customer Project Invoice Request's status is With Conflict.
- Choose Edit, then you will get a warning message like 'Item: Conflict in item; cancellation requested but invoice already exists'.
Cause
The Conflict status is explained by the warning message in the Customer Project Invoice Request. This conflict is caused by canceling the Customer Project Invoice Request while the Customer Invoice is still in Released status.
Resolution
If you wish to correct the Customer Project Invoice Request's status and finish reversing the invoicing, you can cancel the related Customer Invoice. This will revert the Customer Project Invoice Request's status to Canceled and the amount of the Customer Invoice will be available again for invoicing.
Note: The system allows Project invoice request to be canceled before canceling customer invoice to provide flexibility because both documents in general are handled by different departments at users end. In general, we recommend canceling the last document (customer invoice) first in order to avoid inconsistencies in the system.
Keywords
Conflict, Cancellation Requested but Invoice Already Exists, Customer Project Invoice Request , KBA , cpir is canceled before cancelling civ , SRD-PRO-INV , Projects Customer Invoicing , AP-PRO , Project Processing , How To