SAP Knowledge Base Article - Public

2472975 - Unable to Extract Data Using Data Extraction Workcenter.

Symptom

You get an error when you extract data using Data Extraction workcenter. When you check the Application Log you see the below error, however it does not specify the cause for job fail.

Error: 1 work packages failed; for further information see details section

 

Reproducing the Issue

  1. Go to Application and User management workcenter
  2. Select Data Extraction view
  3. Select New button
  4. Select the required Extraction Object and give a Run ID and save

Cause

The job fails as there is not enough memory available. Depending upon the number of records/data in required Extraction Object, probably the package size used is too large.
Unfortunately, the correct package size depends on various factors therefore only best guess works in this scenario.

Backend Error:  Runtime Errors TSV_TNEW_OCCURS_NO_ROLL_MEMORY

Resolution

  1. Go to Application and User Management workcenter.
  2. Select Data Extraction view.
  3. Select New button.
  4. Select the Package Active checkbox and provide the number of instances. 
    Enabling definePackage Size automatically performs the extraction in packages with each package containing the number instances selected.
  5. Select Extraction Object and give a Run ID and save

 

Keywords

KBA , work packages failed , data extraction , tsv_tnew_occurs_no_roll_memory , SRD-CC-MIG-DXT , BYD- Data Extraction Tool , How To

Product

SAP Business ByDesign all versions