SAP Knowledge Base Article - Public

2473126 - When you Add a Registered Product to a New Ticket you Receive the Message Invalid Entry

Symptom

The users without a Administrator rights cannot add Registered Products to a Ticket due to the error message Invalid Entry.

Reproducing the Issue

  1. Login with the user ABC (ABC represents the ID of the user).
  2. Go to the Service work center.
  3. Select Tickets view.
  4. Click on New.
  5. In the field Registered Products, search for Product XYZ (XYZ represents the ID of the Registered Product).
  6. An error message will appear Entry is not valid.
  7. Now go to the Products work center.
  8. Select the Registered Products view.
  9. Change the search to All and search for Product ABC.
  10. You will be able to see that the Product exists and is Active.

Cause

By default, users can only view entries in the Object Value Selector (OVS) that correspond to instances accessible through their assigned Work Center Views.

If a user does not have authorization for the relevant Work Center View, the OVS will appear empty and no entries will be displayed.

The introduction of RBAM (Role-Based Access Management) restrictions in OVS represents an incompatible change and has the following impact:

  • Users with access to the corresponding Work Center View
    These users will only see instances in the OVS that are also visible within that Work Center View.

  • Users without access to the corresponding Work Center View
    These users will not see any entries in the OVS.

To ensure proper functionality of the OVS, the required Work Center View must be assigned to the user, as outlined below:

OVSRequired Work Center View
Installed Base OVSInstalled Base
Installation Point OVSInstallation Points
Registered Product OVSRegistered Products



The screenshot below illustrates an example of Work Center View assignments.

 scree.png

Resolution

The solution to this issue is under investigation.

Keywords

KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions