SAP Knowledge Base Article - Public

2473186 - Custom Checkbox Field in Ad Hoc Reports - Performance Management

Symptom

This KB article explains how to configure custom checkbox fields in a form as reportable within Adhoc Reporting

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Create/Run an Adhoc report and notice the custom checkbox field values are empty.
  2. The report shows the field name and values configured for the section; however, it does not show the checkbox selection made by the end-user.

evalue 3.png

Cause

There are no evalues defined for the custom checkbox fields in that section:

evalue2.png

Resolution

  • Check the template XML to make sure there are evalues defined for each custom checkbox.

Note: Download the template xml via Admin Center > Form Template Settings > Download Form Template.

  • The example below shows the evalue defined as "Y":

evalue4.png

  • This is the value stored when the user checks the box.
  • If no value is specified, then no value is stored in the database.
  • With the evalue defined, the custom checkbox field value selected in the Adhoc report will be visible:

evalue6.png

Note: This value cannot be added to live forms. If forms are launched with no value defined, make the correction, delete current forms, and relaunch.

Keywords

sf, success factors, PMGM, PM, review, ad hoc , KBA , LOD-SF-PM-FRM , Forms & Templates , How To

Product

SAP SuccessFactors HCM suite all versions ; SAP SuccessFactors Performance & Goals all versions