Symptom
When scheduling an interview for an applicant, you get an error saying "Server connection failed" or "Exception fetching availability"
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Recruiting>Interview Scheduling
- Click on an interview not started
- Choose an interviewer and click "Find Availability":
- You receive an errors.
Cause
There are few possible causes:
- You do not have a service account for the interviewer set up in outlook integration for interview scheduling.
- Interviewer's Employee Profile email address is invalid
- Service Account does not have access to the Interviewer's Calendar due to an on-premise Outlook model being used.
Resolution
- Admin Center>Manage Users
- Check the email address of the interviewer you are looking to set up:
- Get the credentials of the interviewer's service account and verify and establish the outlook integration for interview scheduling. Please refer to KBA 2978862 to see how to set up outlook integration for interview scheduling:
- Try again to find an availability for the same interviewer:
When the Service Account does not have access to the Interviewer's Calendar due to an on-premise Outlook model being used (or a hybrid one), please ensure that Outlook Exchange Online is being used.
Please also note that the "Server connection failed" error will prevent Interview Scheduling related emails to be received successfully.
See Also
2978862 - Interview Scheduling Outlook Integration Using Modern Authentication - Recruiting Management
Keywords
outlook, find, availability, time, slot, email, not, found , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , Problem