Symptom
When opening the manage business configuration UI or any section under manage business configuration you are getting an error similar to the screenshot below.
You are not allowed to make changes to *** configuration due to following issue, Rule [***] are not defined in the system but referenced in the configuration, To resolve it, kindly configure these rules in the system using "Configure Business Rules" or delete from the XML data model.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central
- Manage Business Configuration (BCUI)
Reproducing the Issue
- Go to admin center
- Manage business configuration
- Navigate to every section
- See the error
Cause
- This error message is a validation and basically what it is saying is you have certain business rules declared in your succession datamodel (SDM) that do not exist in your system (If you try to search it in Configure Business rules you will not find it).
- This may happen if for example you type the name of the rule incorrectly, or if after you import the datamodel you delete the business rule from the system in Configure Business Rules.
- If you have business rules in your datamodel that do not exists in the system, it may cause unexpected behaviors like some business rules not being properly triggered, thus this validation exists.
Resolution
There are two possible resolutions:
- Create the business rule returned in the error message under Configure Business Rules, this will fix the datamodel inconsistency
- Delete the business rule returned in the error message from the datamodel, this will also fix the datamodel inconsistency
Keywords
SF, success factors, EC, BCUI, data model, datamodel , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , LOD-SF-EC , Employee Central , Problem