Symptom
There is an item missing from a Picklist.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Look for specific item in dropdown menu
- Item is not present
Cause
The item has not yet been added to the Picklist for the affected dropdown menu.
Resolution
1. Navigate to 'Picklist Management'
2. Click on 'Export all picklist(s)' -> Check mark 'Include System Generated Job Codes' & 'Process as a batch Process' -> Click Submit
3. While staying on this page, Perodically click 'Refresh' until you have the 'Download' option -> Click Download -> Select a place to download this file to on your computer
4. Extract the file -> Open the file
* This file contains every picklist in your system currently, and the translations for each work
5. Click 'Export Data Format'
* This will be a blank template
6. Go back to the Picklists you exported previously -> We need to locate the picklist we want to update
* In my example, I am updating 'ACADEMICDEGREE_ARE'
7. Populate the fields under neath the first line with the options & their translations, as seen here in the picture below.
* Your Template may not have all translations avilable in the system, you may only subscribe to 1 or 2 languages, in my example I have 10 different languages
8. Leave 'OptionId' empty for the new item, because the system will automatically generate the OptionId.
9. Save file as CSV.
10. In system -> Select: 'Import Picklist(s)' -> Select 'No' (since this is an old picklist you are updating) -> Choose File (Select your new CSV) -> Submit
11. After this process is done, your picklists are now updated successfully.
Keywords
KBA , legacy picklist , update picklist , LOD-SF-EC-PER , Person Data (All Person Data Types) , LOD-SF-EC , Employee Central , LOD-SF-PLT-PCK , Picklist Management Issue , How To