SAP Knowledge Base Article - Public

2475181 - Business Configuration: An Application Error occurs when selecting a Country Specific element - 1705

Symptom

When navigating to Admin Center > Manage Business Configuration, and selecting a jobInfo Country Specific element, An Application Error Occurs.

Environment

Employee Central 2.0

1705

Cause

One or more of the "Localized HRIS Element" (MDF object) which represents the section in the UI, is missing a "Country" value (and also the Default Label)  -:

Country_Missing_inObject.jpg

 

This issue impacts nearly al of the Localized HRIS Element. If you navigate to Admin Center > Import and Export data and export the data for the object "Localized HRIS Element" you will see most Country Specific objects do not have a Country value set (which is Required) -:

LocalizedHRISElementExport.jpg

Resolution

Note that the following resolution will not lost any configurations made for Country Specific elements. This will only remove the current BCUI object that is created, and then recreate the same object based on the XML configuration

Resolution Steps

1) Navigate to Provisioning Download the Country Specific Succession Data Model XML for the instance.

2) Next we need to delete all of the "Localized HRIS Element" data objects that are created

  1. Navigate to Admin Center > Import and Export data and Export the data for the object "Localized HRIS Element"
  2. Navigate to Admin Center > Monitor Job to download the export file
  3. Open the CSV file "Localized HRIS Element.csv"
  4. Add the word "Delete" to the [OPERATOR] column for all rows (even if they have a Country value)
  5. Save the file to your Desktop
  6. Navigate to Admin Center > Import and Export data and Import the data for the object "Localized HRIS Element" (in Incremental Load mode)
  7. This will delete the BCUI references to these Country Specific element configurations

3) Navigate to Provisioning and import the Country Specific Succession Data Model XML file you downloaded in step 1. This will trigger the Synchronize Business Configuration job (which you need to wait for it to complete)

Once the job is completed, log back into the instance again and the Country Specific elements in Manage Business Configuration will be available again.

Fixed2.jpg

 

NOTE: SAP Product Support please refer to Internal Memo for Application log example

Keywords

fingerprint=1416c69a8febf6ccf178419ae08dbb620f7ea442 com.successfactors.businessconfig.bean.dm.ECLocalElementConfig.getCountry() Business Configuration UI, BCUI, Country Specific, error 1705 ECT-73970 , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , Problem

Product

SAP SuccessFactors Employee Central all versions