SAP Knowledge Base Article - Public

2476874 - Product Category Replicated From ERP to C4C are created with # at the beginning

Symptom

New product categories replicated from ERP to C4C are getting created with # in the beginning.

Environment

  • SAP Hybris Cloud for Customer
  • SAP ERP 

Reproducing the Issue

  1. Product Category replicated to C4C with # as the first character followed by the category ID.
  2. IDoc contains the category ID without # and C4C Incoming Message contains the category ID(ReceiverInternalID) with #.

Cause

  1. The # appended before the Product Category is due to the standard mapping that is provided by SAP.
  2. Please check the screenshot(Mapping1) attached. This logic is defined because most of the customers will create Product Categories with leading zero's .
  3. However in C4C , we don't consider leading zeros while we show the data on UI or save the data in backend.
  4. To make sure that leading zeros are not removed , we pass # which will get appended as first character.

Resolution

  1. If you do not use leading zeros when creating a product category in ERP, you can adjust the mapping as per the screenshot attached(Mapping2).
  2. As highlighted in the screenshot, you can remove the logic to concatinate # with ID.
  3. Instead you can map ID(from IDoc structure) to ReceiverInternalID(C4C structure) and this will fix this issue.

Keywords

ERP , leading zero, integration, inbound , outbound , 0 , leading 0 , cloud for customer , products , material , master data , UI , Category, Product , IDOC , XML , map , receiverinternalID, C4C , KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer core applications all versions

Attachments

Mapping1.JPG
Mapping2.JPG