SAP Knowledge Base Article - Public

2478221 - You Encounter Error Messages While Posting Goods Issue or Creating Outbound Delivery Against a Return to Supplier Proposal

Symptom

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

You are trying create an Outbound Delivery without Release or with Release for Return to Supplier, and get the below list of errors even though there is enough quantity of the Product DEF (DEF represents the Product ID) available in the Location LOC (LOC represents the Logistics Area ID) when you check in Stock Overview.

  1. Create Outbound Delivery and Goods Issue.
  2. -----> Determination of  source inventory failed for product DEF.
  3. ----------> Inventory in logistics area  not available.
  4. -----> Inventory in logistics area not available.
  5. Error during warehouse request release.
  6. Error processing warehouse request; action not executed.
  7. Action failed.
  8. Save failed; refresh list to perform further actions.

Environment

SAP Business ByDesign.

Reproducing the Issue

  1. Go to the Outbound Logistics work center.
  2. Select the Delivery Control view and the sub-view Delivery Proposal.
  3. Select Return to Supplier Proposals from the Show drop-down.
  4. Find and select the relevant Return To Supplier RTS (RTS represents the Return to Supplier ID) for which you want to create an Outbound Delivery.
  5. Choose the Create Outbound Delivery with/without release button.
  6. The system throws up the above listed error and warning messages, but you have confirmed that the Product is available in the Logistics Area.

Note: This is also applicable if you click on the 'Post Goods Issue' instead of the 'Create Outbound Delivery' button.

Note 2: This is also applicable to serialized Material where the Action fails with the error: -----> Serial number XYZ not restricted in inventory; cannot be issued (XYZ represent the Serial Number ID you are trying to return to the Supplier).

Cause

When you choose 'Post Goods Issue' button, 'Create Outbound Delivery and Goods Issue' screen opens up. In this screen, there is a 'Restricted' field checkbox.
For Product return to supplier scenario, this field is automatically filled as 'Yes'. This means only stock which is marked as 'Restricted' can be used.
In this case however, there is no stock available which is marked as 'Restricted' and that is why you are getting the error.

The system is designed this way, because normally when you get Product from Supplier, you may want to mark Product to Return (e.g. damaged products) as 'Restricted' stock, so as to differentiate Product Returns from other Products.

Resolution

  1. Go to the Outbound Logistics work center.
  2. Select the Delivery Control view and the sub-view Delivery Proposal.
  3. Select Return to Supplier Proposals from the Show drop-down.
  4. Find and select Return To Supplier RTS.
  5. Click the Create Outbound Delivery with/without release button.
  6. In the 'Create Outbound Delivery and Goods Issue' screen, select 'No' in the 'Restricted' drop-down field. After doing so, system will not give any error and you will be able to successfully post the goods issue.

See Also

RTS_Restricted_Stock.png

Keywords

Return To Supplier, Goods Issue, Inventory in logistics area not available, Determination, source, Logistics Area, Serial number not restricted in inventory cannot be issued , KBA , post goods issue , outbound delivery , rts , return , supplier , AP-ODP-ODR , Outbound Delivery Request , How To

Product

SAP Business ByDesign all versions