Symptom
- Onboarding Candidates not syncing/moving to BizX;
- New Hire Email/welcome emails (which are triggered from BizX) not sent or delivered to Candidate;
- Picklist Unavailable in panel/front end.
Environment
SAP Successfactors Onboarding 1.0
Reproducing the Issue
Scenario 1:
- Create a new hire in Onboarding 1.0;
- New hire will not be moved/synced to BizX.
Scenario 2:
- New Hire did not received the welcome email and is not able to login to BizX;
Scenario 3:
- Picklists are showing as UNAVAILABLE in Onboarding Panels.
Cause
This issue is caused by the integration between Onboarding and BizX. The error message can be found in:
- Go to Onboarding > Settings > Audit Logs;
- In the Event Type, insert the event SF_INTEGRATION;
- You'll notice a few errors such as: Failed to send data to SF: The remote server returned an error: (403) Forbidden..
Resolution
- Review the conection between BizX and Onboarding 1.0 (Validate in provisioning and also in Onboarding SuperAdmin);
- Validate if the key BX.OAuth.Secret has some value in Onboarding SuperAdmin > Account Options > BX.OAuth.Secret;
- Validate if the API user provided in Onboarding 1.0 SuperAdmin > Features > SF_BizX_Connection has enough permissions in BizX.
If the key BX.OAuth.Secret is not available in Onboarding SuperAdmin, try to disable/enable the Onboarding 1.0 conection in BizX Provisioning. That will recreate the key in Onboarding 1.0. If that does not work, please log a ticket to SAP Support.
See Also
Keywords
SF_INTEGRATION, 403, Forbidden, error, New, Hire,Email, not, triggered , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , Problem
Product
SAP SuccessFactors Onboarding