Symptom
Customer/Partner is receiving error while running a Provisioning job for Job Requisition import:
XXXXXXX : com.successfactors.sca.service.ServiceLegacyRollbackException: Wrapped Exception: DAOExceptionSQLException caught: SAP DBTech JDBC: [287]: cannot insert NULL or update to NULL: Not nullable "USERS_SYS_ID" column(input position -1)
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
Run the Provisioning job for Job Requisition import (from a csv file) and receive the above error.
Cause
There might be different causes for this error; one of the most common causes is that Recruiting Team Settings have been enabled in Admin Center in the instance.
For example, if the requisition template (XML) does not contain the "coordinatorTeam" field and the Coordinator Team is enabled in Admin Center >> Manage Recruiting Team Settings, then there will be a mismatch betweem the XML and Recruiting Team Settings.
Resolution
This issue can be resolved by the following:
Disable each of the teams in Admin Center >> Manage Recruiting Team Settings and then try importing the csv file for Job requisition import. After disabling the Recruiting Team Settings, the import should work fine. The csv file does not have values for team recruiting. So disabling each team will not cause any issues. It can be re-enabled after the import is completed.
See Also
Keywords
Error, Job, requisition, import, cannot, insert, NULL, ServiceLegacyRollbackException , KBA , LOD-SF-RCM-SYS , System Performance, Usability, Errors, Security , Problem