Symptom
Adding Sales Kits in the creation/update of Sales Orders via Web Service ManageSalesOrderIn.
Environment
SAP Business ByDesign
Reproducing the Issue
- Logon to the Soap UI.
- Execute the payload to create/update a Sales Order.
- Logon to the Business ByDesign system.
- Go to the Sales Order Work Center.
- Go to the Sales Orders View.
- Filter for All Orders.
- Search for the Sales Order ABC (where ABC represents the Sales Order ID).
- Open, Select View All.
- Navigate to the Items tab.
The Kit Header and Kit Sub Items are displayed in the newly created Sales Order document.
Cause
When using Sales Kits for the creation/update of a Sales Orders via Web Service, it is only required to specify the Kit Header ID as the Product ID in the payload. The expansion of the Kit Header into the Kit Sub Items is done automatically by the system.
Resolution
This is the designed system behavior
Keywords
Kit Header, Kit sub Items, Web Service, ManageSalesOrderIn, Sales Kits , KBA , managesalesorderin , SRD-CRM-ORD , Orders & Contracts , How To