Symptom
The service order line item remains in process for spare parts even when you use the function complete execution.
You will get the warning message Item ABC: Order item ABC not fulfilled Completely; Open quantities exist
Reproducing the Issue
- Go to the Service Orders work center.
- Go to the Service Order Processing view.
- Search and opem the service order XYZ (XYZ represents the ID of the service order).
- Select the Edit button.
- Select the View All button.
- Select the Tab Items
- Search for the line item ABC
Here you can see, that the confirmed quantity has not reached the quantity in the line item.
- Click on Complete Execution
Now you will get the warning message:
Item ABC: Order item ABC not fulfilled Completely; Open quantities exist
The status still remain in process.
Cause
In the Services, Spare parts cannot be completed with creating a confirmation with 0 quantity or a quantity which is less than requested in the line item.
For a spare part ( delivery relevent ) completion happens only when the total requested quantity is delivered and confirmation is created for the full quantity.
Resolution
This is the expected system behaviour.
Keywords
KBA , service orders , remains in process , item abc: order item abc not fulfilled , SRD-CRM-ORD , Orders & Contracts , How To