SAP Knowledge Base Article - Public

2479967 - Role of Convert to Account And Convert to Contact in Leads

Symptom

Convert to Account and Convert to Contact options for Leads are maintained in fine-tuning. You want to know under which conditions these are shown under the Actions button within the Leads TI.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Business Configuration work centre.
  2. Select the Implementation Projects view.
  3. Select the respective project.
  4. Click the Open Activity List button.
  5. Select the Fine-Tune facet.
  6. Search and open the Leads activity.
  7. Click the Maintain Status hyperlink.
  8. In the new opened window you see that there are the options Convert to Account and Convert to Contact and you would like to know under which conditions these are shown under the Actions button within the Leads UI. 

Cause

There are dependencies for these options to show in the UI.

Resolution

Convert to Account will show up if you have a lead with inactive account but no contact.

 This can occur in case that contact is not mandatory. User enters company name and address without any contact details. So during conversion only convert account is relevant . This action will show up instead of regular Convert to account & contact action.

Convert to Contact will show up if you have a lead with an active account but inactive contact.

This can occur only in cases of Hybris marketing integration scenario. With that scenario active, users can pass two leads with the same inactive account but different inactive contacts. During conversion of the first lead in C4C, the account is replaced for both leads. So the second lead will end up with an active account but inactive contact. Only at this point, you can see the Convert to Contact action.

See Also

 KBA 2675862 - The Actions Convert to Contact and Associate Contact are disabled in the Lead TI

Keywords

Account, Lead, Contact, , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions