Symptom
- "Failed to connect to the BI platform" error displayed when trying to get the list of the universes in the query browser
- SSL connection is used for communication between the SAP BusinessObjects BI server and Dashboard designer
- If Fiddler is running in the background with SSL decryption and ignore ssl errors then the workflow is successful
- When testing the https://server:port/dswsbobje address in Internet Explorer, certificate error is displayed
Environment
- SAP Dashboards 4.x
- SAP BusinessObjects Business Intelligence Platform 4.x
Reproducing the Issue
- Launch Dashboard Designer
- Go to Query browser and click on 'Add query'
- In the authentication window, enter the details of a BI4 server configured with SSL
- Click 'Next'
- Error: "Failed to connect to the BI platform. If this error keeps occurring then refer to SAP Note 1668437 for troubleshooting"
Cause
- This issue occurs if SSL (Secure Sockets Layer) is implemented on servers and SSL certificate is missing on client machine.
- The SSL certificate is expired
Resolution
- Deploying/Re issue the SSL certificate resolves the issue, since it is expired. Dashboards and Adobe Flash player can work with non expired certificates only due to security restrictions.
See Also
- 1777096 - No values for SAP NetWeaver BW connection / Error #2032 / unable to get list of universes in Dashboards when using https / SSL
Keywords
ssl, expired, certificate , KBA , BI-RA-XL-DSL , Obsolete: Design-Time, Design on Multi-Source , Problem
Product
SAP BusinessObjects Dashboards 4.1 ; SAP BusinessObjects Dashboards 4.2 ; SAP BusinessObjects Dashboards software 4.0