Symptom
You have configured a business rule on an effective dated portlet.
Within the rule you are checking if a value is equal/not equal to a pervious value.
The rule is not working.
When checking the rule trace, you can see the values are being checked correctly, but the checking is not returning the correct result and the rule is not working.
Cause
This issue occurs when checking picklist fields.
The issue for the rule not working correctly and you not seeing the correct behaviour in the rule trace, is that no external codes are maintained for the picklist values.
Resolution
To resolve the issue, please update the picklist values and provide a unique external code for each picklist value which may be used.
It is always best practice to maintain external codes for picklist values to mitigate issues like this.
Keywords
pervious value rule rule trace not working fail business rule , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , Problem