SAP Knowledge Base Article - Public

2482459 - Scheduled Project Invoice Request is not Created automatically

Symptom

Customer intents to create a new Scheduled Project Invoice Request and receives an alert: Action triggered; verify result in Work view in a few minutes but nothing happens after that.

or

Error Customer Invoicing not possible; posting to financial accounting is blocked on XX:XX:XXXX

Environment

SAP Business Bydesign

Reproducing the Issue

  1. Go to the work center Project Management.
  2. Go to the view Invoice Preparation.
  3. Select the subview Project Invoice requests 
  4. In the advanced search, filter for the relevant Reference Sales Order ID.

You do not get any results for this sales order as no scheduled project invoice request has been created.

Every night a regular job runs automatically and it creates project invoice requests on the next day.

When the invoice date is reached, an invoice run processes the invoices based on the invoice requests.

 or

  1. Go to the Project Management workcenter and navigate to the Projects View and there choose the Projects subview.
  2. Show All Projects and navigate to the respective project.
  3. Click on the Project Identifier icon right beside the project ID and there choose Create Scheduled Project Invoice Request.
  4. The alert appears: Action triggered; verify result in Work view in a few minutes
  5. Nothing happens after that.

Cause

Cause 1: The Invoice schedule is created for the date DD.MM.YYYY. Every night a regular job runs automatically. This job automatically creates Scheduled Project Invoice Requests on the next day (DD+1.MM.YYYY).

Cause 2: While automatic invoice schedule run checks for the time and expense, if there are no time and expenses available against project and sales order to create project invoice request the system failed to create the schedule project invoice request and generates the error task.

Cause 3: If there are time and expense available these might be assigned to the different sales order, in this case, you need to reassign the expense to be invoiced sales order using the "Apply assignment rules" button.

Follow the below steps to see the task.

  1. Go to Customer Invoicing Work Center.
  2. Choose the Work View.
  3. Choose the relevant task associated to a sales order.
  4. You can see the task Solve Issue When Creating Project Invoice Request - Creation of project invoice request failed.
  5. Choose the Edit button.
  6. You will see the application log XXXXX (XXXXXX represents the application log ID).
  7. Go to Results tab here you can see the error Expenses do not exist; CPIR not created.

Cause 4: There is an open task "Task - Solve Issue When Creating Project Invoice Request"

Casue 5: For scheduled invoices the system creates invoices for the whole scheduled period. Therefore a possible cause why invoices were not created is that not all respective accounting periods are open for posting.

Resolution

Case 1: The Scheduled Project Invoice Request will be created on DD+1.MM.YYYY for all the time and expenses up until DD.MM.YYYY. This document will have DD.MM.YYYY as its Invoice Date and will include Time and Expenses From/To unlimited / DD.MM.YYYY.

Case 2: If you are sure, you don’t expect any expenses might occur for the project then you must delete those invoice schedule items from Sales Order so that it won’t consider for execution in future and complete the Task.

Case 3: If you expect expense that needs to be billed to your customer, ensure to have the time and expense before the schedule, which can be checked by following the below steps

  1. Go to Project management work center
  2. Go to Not invoiced time and expenses
  3. Click edit time and expenses
  4. If there are time and expenses available then validate if they are assigned to the respective sales order for which you want to create Invoice then reinitiate the schedule project invoice request creation.   
  5. If these expenses are assigned to different sales order then change the assignment rules accordingly using the button "Edit assignment rules" then perform the reassignment using the button "Apply assignment rules" and save button. 
  6. Assign manually to the right sales order and ensure the item for Sales Order is also correct.

Case 4: If you wish to have the project invoice request immediately, please perform the forced schedule by following below steps:

  1. Go to Project Management work center.
  2. Select the Project XYZ.
  3. Click on new button an choose project invoice request.
  4. Next, to it there arrow mark click it and choose to Create a scheduled project invoice request.

Case 5: If you have scoped the below question the system retries automatically to generate using invoice schedule run.

Do you want the system to retry project invoice request creation automatically in case of creation failure during an invoice schedule run?

If not you have to change the schedule dates accordingly to regenerate the schedule project invoice request automatically.

Follow the steps:

  1. Go to Sales Order work center.
  2. Select the Sales Order ABC.
  3. Go to Pricing and Invoicing -> Invoice Schedule tab.
  4. Here change the dates to the required date.

Case 6: Ensure to check what values you have maintained  in this activity.

  1. Go to the work center Business Configuration.
  2. Go to the view Overview.
  3. Search for the activity "Project Invoice Request Creation Settings with Invoice Schedule".

Here you can define how many days in advance or in the future the project invoice request should be created.

If you have defined 5 days, the scheduled project invoice request will be created 5 days after the date maintained in the invoice schedule of the sales order.

If you have defined -5 days, the scheduled project invoice request will be created 5 days  before the date maintained in the invoice schedule of the sales order.

Case 7: Follow the below steps to see the task and error.

  1. Project management work center.

  2. Work view.
  3. Enter sales order ID in advanced filter.
  4. Click on Action Log ID.
  5. Click on results tab.
  6. Expand the description.
  7. Here you can check if there were any issues raised during the scheduled invoice creation .

Case 8: To check if the accounting periods are open

  1. Go to the General Ledger workcenter and here to the Common Tasks.
  2. Choose Open and Close Periods.
  3. Select the accounting period in which you need release the invoice.
  4. Check if the accounting period is open for operational postings (first allowed step: 010-Operational Postings; last allowed step: 010-Operational Postings or 020-Closing Entries).
  5. In Details section ensure that the Process Control is configured correctly and that posting into the period is still/ already possible.

Steps to release the invoice.

  1. In the Project Management workcenter go to the Invoice Preparation view and choose the Work subview.
  2. Select Advanced (for advanced search option).
  3. Search for the project ID reference and click Go.
  4. Select the row and click Edit to open the corresponding task.
  5. In the task choose Actions and select Retry to trigger the scheduled invoice request creation.

See Also

Keywords

Expenses; Project Invoice Request, CPIR, Schedule, Job Run
, KBA , SRD-PRO-INV , Projects Customer Invoicing , How To

Product

SAP Business ByDesign all versions