Symptom
- An SAP Analytics Cloud (SAC) live model is configured with a direct connection using CORS by following the steps of the live data connection online help.
- The below errors appear in the browser when verifying the connection using the "GetServerInfo" URLs, for example:
- HANA: https://<Your_HANA_System>/sap/bc/ina/service/v2/GetServerInfo
- BW or BW/4HANA: https://<Your_ABAP_System>/sap/bw/ina/GetServerInfo?sap-client=<Your_Client_ID>
- BPC NW embedded model: https://<Your_ABAP_System>/sap/bw/ina/GetServerInfo?sap-client=<Your_Client_ID>
- SAP Universe: https://<Your_Live_Universe_Connect_Tomcat:TomcatHttpsPort>/sap/boc/ina/GetServerInfo
Possible error messages:
- Failed to connect to <> system. Possible causes: SSL certificate untrusted, network error.
- Failed to connect to <> system. Possible causes: The SSL certificate is not trusted, or a network error occurred.
- Not secure
- Your connection is not private
- Attackers might be trying to steal your information from yourhanaserver.yourdomain.com (for example, passwords, messages, or credit cards).
- NET::ERR_CERT_AUTHORITY_INVALID
- "_error": "net::ERR_CERT_AUTHORITY_INVALID"
- ERR_CERT_WEAK_SIGNATURE_ALGORITHM
Other errors captured in Chrome Developer tools (network or console tabs) may include:
- ERR_TUNNEL_CONNECTION_FAILED
- Error: "Subject Alternative Name Missing"
- NET::ERR_CERT_COMMON_NAME_INVALID
- Failed to load resource:
- net::ERR_NAME_NOT_RESOLVED
Environment
- SAP Analytics Cloud
- Live model data connections:
- SAP HANA (HANA)
- SAP Business Warehouse (BW)
- SAP BW/4HANA (BW4)
- SAP S/4HANA on-premise (S4OP)
- SAP S/4HANA Cloud (S4Cloud / S4HC)
- SAP BusinessObjects Universes (LUC)
- SAP Business Planning and Consolidation, version for SAP NetWeaver (BPC NW) embedded model
Cause
Browser security requirements need to be configured properly to allow certificates, pop-up windows and cookies from SAP Analytics Cloud.
Resolution
Server Security Settings: Certificates
As a prerequisite, HTTPS (SSL) must be enabled and successfully configured on the backend (server) datasource so that secure connections can be established on the port configured for HTTPS.
Please enable SSL on the HTTPS port by following the articles / SAP Notes below:
- SAP Business Warehouse (BW) & SAP BW/4HANA - 2445947 - [WEBINAR] SSL setup on NW Application Server for ABAP and SAP Note 510007 - Additional considerations about setting up SSL on Application Server ABAP
- SAP HANA - 2502174 - HANA Basic How-To Series - Securing HANA XS classic via SSL / HTTPS - using Web Dispatcher Administration and PSE container.
Browser Security settings: Certificates
Note: You need a valid signed certificate from a Certificate Authority (CA) in order to connect securely. (See supported browsers here)
The certificate installed on the server (back-end) system is not trusted in the browser (message: This page is not secure (broken HTTPS)).
- You can verify the certificate if you open the Developer Tools in Chrome: Menu >> More Tools >> Developer Tools (Windows: F12, Ctrl + Shift + I Mac OS: Cmd + Opt + I).
- Once Chrome Developer Tools is opened, click the Security tab.
- Click the View certificate button, and observe that the Certificate / certification authority (CA) is not trusted:
- Install the CA Root certificate authority that signed the certificate by following the below steps:
- Download Root certificate.
- Browse to https://<certification authority host>/ip/certsrv.
- Click "Download a CA Certificate, Certificate Chain, or CRL".
- Click "Download CA Certificate".
- Load Root Certificate into your Windows browser machine:
- Open the Certificates MMC snap-in for a user, computer, or service (run certlm.msc).
- In the console tree, click the "Trusted Root Certification Authorities" Store.
- From the "Action" menu select "All Tasks > Import..." to start the Certificate Import Wizard.
- Select "Local Machine" Store Location and click "Next".
- Type the file name containing the certificate to be imported. (You can also click Browse and navigate to the file).
- Click "Next".
- Select "Place all certificates in the following store".
- Trusted Root Certification Authorities.
- Click "Next".
- Click "Finish".
For further details consult with the IT administrator who signed the certificate to install it in your computer.
Note:
- Due to the following Google Chrome security change, it is not possible to use a self signed certificate. You need a valid signed certificate from a Certificate Authority (CA).
- Chrome SSL certificate problems
See Also
- 2502174 - HANA Basic How-To Series - Securing HANA XS classic via SSL / HTTPS - using Web Dispatcher Administration and PSE container
- Live Data Connection to SAP HANA Using a Direct Connection with Password Authentication
- 2659735 - Troubleshooting CORS issues with SAP Analytics Cloud (SAC)
- How to Enable CORS on SAP NetWeaver Platform | SAP Blogs
- Failed to connect to (source) system when using Live Data connection to SAP HANA On-Premise guided answer
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
2970934 - How to create the CSR and how to import the certificate response for ABAP system - Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
- 3518480 - "This site can’t be reached" or "Hmmm… can't reach this page" when testing GetServerInfo service on browser
Your feedback is important to help us improve our knowledge base.
Keywords
EPM, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning,Cloud for Planning, EPM-ODS, Cloud for Analytics, C4P, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, HCP, C4A, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJ, BOBJcloud, BOCloud., BICloud, BO Cloud, connecting, conecting, conectando, conexão, modelo, SBOC, SAC, popup, popups, pop-up, self-signed, no es seguro, backend, SAC over SAP Universe, bw, bw4, bw4/hana, dw4core, bw4hana, self-signed, selfsigned, SAP BW, stories, geo, story
Failed to connect to <> system. Possible causes: SSL certificate untrusted, network error. (Admin)
Failed to connect to <> system. Possible causes: The SSL certificate is not trusted, or a network error occurred.
Failed to connect to <> system. Please contact your administrator to check possible causes: SSL certificate untrusted, network error. (end user)
Failed to connect to <> system. Please ask your administrator to check that your SSL certificate is trusted, and that your network is working correctly.
Failed to connect to <> system. Possible causes: CORS settings, incorrect credentials. (Admin)
Failed to connect to system. Possible causes: You are using the wrong credentials, or CORS is not configured correctly.
Failed to connect to <> system. Please contact your administrator to check possible causes: CORS settings, incorrect credentials. (end user)
Failed to connect to <> system. Please ask your administrator to check you are using the right credentials, and that CORS is configured correctly.
Failed to connect to <> system. Possible causes: CORS settings, third-party cookies blocked. (Admin)
Failed to connect to <> system. Possible causes: third-party cookies are blocked, or CORS is not configured correctly.
Failed to connect to <> system. Please contact your administrator to check possible causes: CORS settings, third-party cookies blocked. (End User)
Failed to connect to <> system. Please ask your administrator to check that third-party cookies are not blocked, and that CORS is configured correctly.
Failed to connect to <> system. More information can be found on the troubleshooting page. (Admin)
Failed to connect to <> system. For more information, see our troubleshooting page.
Failed to connect to <> system. Please contact your administrator to check possible causes. (End User)
Failed to connect to <> system. Please ask your system administrator to investigate.
401, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped, sap analyst cloud, https://hcs.cloud.sap, https://hanacloudservices.cloud.sap, https://cloudanalytics.accounts.ondemand.com, https://hanacloudservices-us.accounts.ondemand.com, https://www.sap.com, https://help.sap.com, predictive analytics (analysis), data analysis (analytics) tools, analytics tools, sap analytics cloud, data literacy, advanced analytics, data democratization, analytics software, real time analytics, self service analytics, advanced data analytics, analytics as a service, analytics cloud / cloud analytics, saas analytics, cloud bi, enterprise planning, cloud data analytics, cloud based analytics, analytics cloud platform, modern analytics, real time analysis, cloud analytics solution(s), what is sap analytics cloud, cloud analytics tools, analytics in the cloud, cloud analytics software epm, business intelligence,
, KBA , not secure , install certificate sso sac kba , analytic model creation, url showing not , página no segura , página insegura , não é seguro , page non sécurisée , unsichere seite , pagina non sicura , login error in boe: 'unauthorized' , ssl created for sac ssl certificate for , ssl certificate for sac , to use for sac , "no seguro" , error "failed to connect to system". , are you asking what ssl certificate to u , 401 not authorized , net::err_failed , LOD-ANA-LDC , SAC Live Data Connection , LOD-ANA-ADM , SAC Administration , LOD-ANA-LDC-BW , SAC Live Data Connection BW , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , LOD-ANA-LDC-UNV , SAC Live Data Connection Universe , LOD-ANA-LDC-WBI , SAC Live Data Connection WEBI , Problem