Symptom
When creating a new Ticket, User can select accounts owned by other employees, even though you have maintained the proper access restrictions for Accounts.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open Service Work Center.
- Go to Tickets View.
- Click on New.
- Select a customer on Customer field - You are able to view customers owned by other employees.
Cause
There are three fields for Customers in the Ticket screen and they have different behaviors.
Resolution
The fields and behaviors are listed below:
- Customer: considers both Accounts and Individual Customers. Has no restritction whatsoever.
- Account: considers only Accounts and has access restriction based on the Accounts view of the Customer workcenter.
- Individual Customer: considers only the Individual Customers and has access restriction based on the Individual Customers view of the Customers workcenter.
Keywords
Customer ; access ; business role ; restricted ; business user ; see , KBA , ticket , account , access restriction , customer , LOD-CRM-EMP , Employee , How To
Product
SAP Cloud for Customer core applications all versions