Symptom
You have added Prefix in the name of the contact but it is not shown.
Reproducing the Issue
- Go to Customers Workcenter
- Go to Contacts View
- Select show all and open the contact
Even though prefix is maintained in the header , you will see that it is not incorporated in the name of a contact person between the first and last name.
Cause
If the contacts are created before the name format rules for netherlands (to consider prefix) have been added then the formatted name and the current Business Configuration don't fit together.
In this case user has added /changed the Business Configuration then the contacts have to be added with prefix manually so that that the new settings are applied.
It's strongly recommended to maintain the name format rules using steps below , before creating contatcs in the system
- Go to Business Configuration workcenter
- Open the acitivty General Business Partners
- Select Maintain Name Formats
Here you specify name formats to define the sequence in which the full names of persons are presented.
Resolution
This is the expected system behavior.
Keywords
KBA , AP-RC-BCT , Business Config. Tools (SAP Business ByDesign , How To