Symptom
When searching for a Contact in the Value Help for Name when adding a role to Involved Parties in Opportunity TI, you find it does not return the right value: instead of the Contact, the system returns the Account the Contact is assigned to.
Reproducing the Issue
1. Go to the Sales workcenter
2. Go to the view: Opportunity
3. Open any Opportunity
4. Go to the tab Involved Parties
5. Click Add
6. In the pop-up window, select 'Ship-To' for Role
7. Click the Value Help for the Name field
8. In the pop-up window, click the icon for Advanced Search
9. In field Contact ID, type in a Contact ID ABC and click Go (ABC is the ID of a Contact)
-> returns: XYZ (XYZ is the Account that the Contact belongs to)
10. For comparison, type in ABC in field Business Partner ID and click Go
-> returns: ABC
Cause
In such a general role, the Business Partner can be pretty much anything (Account, Contact, Partner Contact, Organization, etc).
Therefore, the Value Help for Role is a search for Business Partners in general.
Please note that when you open the Advanced Search in this Value Help, all of the search parameters are referring to the Business Partner that you are searching for.
So in our example: when you put ABC in the Contact ID search field, you are searching for Business Partners that have contact ABC. Since the Contact is not a Contact for itself, the Contact would not be returned in the result list.
Resolution
If you want to search for the Contact ABC, you would put ABC in the Business Partner ID search parameter field. Since that is the ID of the contact, it will be returned in the result list.
This is the expected behaviour.
Keywords
KBA , SRD-CC , Cross Components , How To