SAP Knowledge Base Article - Public

2485178 - ContentDeploymentException:Could not connect to SFTP server

Symptom

When trying to import content the following error is received:

ContentDeploymentException: ........ Could not connect to SFTP server.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Import the content at Learning Administration >
  2. Content >
  3. Import Content >
  4. The background job shows the status "Failed".

If needed, you can review the background job status by going to:

  1. System Administration >
  2. Background Jobs >
  3. Search for the title "Content Import" and access the job that failed.

If the error does not provide enough information, go to:

  1. System Administration >
  2. Configuration >
  3. System Configuration >
  4. Open LMS_ADMIN in the edit mode >
  5. Set reportStackTraceToUser=true >
  6. Save >
  7. And repeat the import.

With that, there will be a large error mentioning more details.

Cause

The error "Could not connect to SFTP server" happens because the password setup in the deployment location is incorrect.

Resolution

  1. Follow the steps for Deployment Location setup in KBA 2416189 >
  2. Correct the iContent SFTP credentials provided in the Deployment Location (you can test it by manually logging into the SFTP URL in a separate browser session/tab) >
  3. After that, retry the import.

See Also

2256194 - Import Content Tool - Failed

2416189 - How to setup and use iContent with Learning

Keywords

lms, learning, sf, SuccessFactors, ContentDeploymentException, content, import, could, not, connect, SFTP, server, auth, fail, unable, deploy, zip, file , KBA , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS-CNT , Content , LOD-SF-LMS-PCM , iContent , Problem

Product

SAP SuccessFactors Learning all versions