Symptom
When trying to import content the following error is received:
ContentDeploymentException: ........ Could not connect to SFTP server.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Import the content at Learning Administration >
- Content >
- Import Content >
- The background job shows the status "Failed".
If needed, you can review the background job status by going to:
- System Administration >
- Background Jobs >
- Search for the title "Content Import" and access the job that failed.
If the error does not provide enough information, go to:
- System Administration >
- Configuration >
- System Configuration >
- Open LMS_ADMIN in the edit mode >
- Set reportStackTraceToUser=true >
- Save >
- And repeat the import.
With that, there will be a large error mentioning more details.
Cause
The error "Could not connect to SFTP server" happens because the password setup in the deployment location is incorrect.
Resolution
- Follow the steps for Deployment Location setup in KBA 2416189 >
- Correct the iContent SFTP credentials provided in the Deployment Location (you can test it by manually logging into the SFTP URL in a separate browser session/tab) >
- After that, retry the import.
See Also
Keywords
lms, learning, sf, SuccessFactors, ContentDeploymentException, content, import, could, not, connect, SFTP, server, auth, fail, unable, deploy, zip, file , KBA , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-ADM , System Admin, Global Variables, References , LOD-SF-LMS-CNT , Content , LOD-SF-LMS-PCM , iContent , Problem