Symptom
You are replicating a Business Partner from ERP to C4C and the incoming message failed with error
"Changing the field not possible; field does not match partner category"
Cause
You have created a Business Partner in C4C with Category Code as 2 [Customer in C4C] and the incoming message you are sending the category code as 1[Natural Person in ERP, Individual Customer in C4C] or viceversa
Resolution
1. This is expected behavior in C4C system.
2. Once a business partner is created with Category Code as 1 or 2 - It cannot be changed again.
For Example:
i) You send a Business Partner to C4C for the first time with Category Code as 2 - Then a new customer record will be created.
ii) If you now send the same record to C4C with Category Code as 1(which means Individual Customer) - this error will be triggered.
Keywords
CategoryCode; NaturalPerson; IndividualCustomer , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To