SAP Knowledge Base Article - Public

2486898 - "New" button is greyed out in Custom Communication Scenarios app - SAP S/4HANA Cloud Public Edition

Symptom

"New" button is greyed out in Custom Communication Scenarios app as shown below:

custom_communication_scenario.PNG

Environment

SAP S/4HANA Cloud Public Edition

Cause

There are three possible causes for this issue:

  1. The Key User Extensibility is not activated in the system.
  2. The system doesn't support Key User Extensibility (for example the Productive System).
  3. "Unrestricted" authorization is not maintained in the Business Role that provides access to this application. The Business Role is Read Only restricted with "Write Access: No Access".

Resolution

  1. Activate the Key User Extensibility in Extensibility Settings app.
  2. Use a system that supports Key User Extensibility.
  3. Review the Business Role which is used to grant access to the application. Change the restriction to "Write Access: Unrestricted" or create a new Business Role unrestricted and assign to the user.

See Also

SAP Help Portal - Extensibility Settings

KBA 2283716 - Key User Application is not configured - SAP for Me

SAP Help Portal | Maintain Business Roles

SAP Help Portal | How to define authorizations based on restrictions

Keywords

Custom communication Scenario, new button, create, button greyed out, extensibility, test, quality, productive, demo, customizing, development, key user extensibility, extensibility settings , KBA , BC-SRV-APS-COM , Maintain Communication System and Arrangement , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud 1705