SAP Knowledge Base Article - Public

2486898 - "New" button is greyed out in Custom Communication Scenarios app - SAP S/4HANA Cloud Public Edition

Symptom

"New" button is greyed out in Custom Communication Scenarios app as shown below:

custom_communication_scenario.PNG

Environment

SAP S/4HANA Cloud Public Edition

Cause

There are three possible causes for this issue:

CAUSE 1: 

You are using a system that do not support Key User Extensibility. 

If you have a 3-System Landscape, you need to ensure that you're using the Customizing Tenant to create your Communication Scenario. It is not possible to create it in Test or Productive Systems.

If you have a 2-System Landscape, you need to ensure that you're using the Test System to create your Communication Scenario. It is not possible to create it in Productive System. 

CAUSE 2: 

You are using the correct tenant (Customizing in 3-SL or Test in 2-SL) but the Key User Extensibility is not activated in this system. 

You can check this information in Extensibility Settings application but checking the switch button "Key User Extensibility". If it's "OFF", then the Extensibility is not active. 

CAUSE 3: 

"Unrestricted" authorization is not maintained in the Business Role that provides access to this application (we suggest to use the template SAP_BR_EXTENSIBILITY_SPEC). The Business Role is Read Only restricted with "Write Access: No Access".

Resolution

SOLUTION 1: 

Use the correct tenant to create your Custom Communication Scenario and transport it to the subsequent systems using the Export Software Collection and Import Collection applications. Check How to Manage and Export Your Software Collection for more information. 

SOLUTION 2:

If the Key User Extensibility button is switched to "OFF", click on it to turn "ON". 

SOLUTION 3:

Review the Business Role which is used to grant access to the application. Change the restriction to "Write Access: Unrestricted" or create a new Business Role unrestricted and assign to the user.

See Also

SAP Help Portal - Extensibility Settings

KBA 2283716 - Key User Application is not configured - SAP for Me

SAP Help Portal | Maintain Business Roles

SAP Help Portal | How to define authorizations based on restrictions

Keywords

Custom communication Scenario, new button, create, button greyed out, extensibility, test, quality, productive, demo, customizing, development, key user extensibility, extensibility settings , KBA , BC-SRV-APS-COM , Maintain Communication System and Arrangement , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud 1705