Symptom
- Activity failed in CPM when a user is made inactive
- In CPM, when creating and saving a new activity or achievement, the below error is shown:
OData Service Achievement Failed, Error Status: error, errorThrown: Bad Request User null does not exist
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Continuous Performance Management
Reproducing the Issue
- User navigates to CPM from the home drop down
- Tries creating an Achievement / Activity and doing a "Save"
- Below Error is thrown depending upon the data being saved:
Cause
The user to whom being proxied has been made inactive.
Resolution
The only workaround is to make the user active in the system.
Keywords
SF, Success Factors, CPM , KBA , LOD-SF-CPM-ADM , Admin Center, RBP. Permissions and Settings , Problem
Product
SAP SuccessFactors HCM Suite all versions