SAP Knowledge Base Article - Public

2487332 - Seniority Start Date is being defaulted from rehire date - Employee Central

Symptom

When we perform a rehire, we notice that the field Seniority Start Date is automatically being populated with the rehire date.

Environment

Employee Central - Employment Information

Reproducing the Issue

  1. Check the Seniority Start Date of an inactive employee;
  2. Rehire the inactive user;
  3. Observe that the Seniority Start Date has changed to the rehire date.

Cause

This is expected system behavior.

Resolution

For new hires, the Seniority Start Date field will have the same date as the hire date.

For rehires, the Seniority Start Date will default from the rehire date due to the following:

A user cannot be rehired into the system unless they have been terminated. The system reads this as the user is terminated from the system and is no longer active. When rehiring the user, the system disregards the seniority that was built up in the previous employment and starts from scratch as of the rehire date.

As an alternative, it is possible to setup onChange and onSave business rules to set Seniority Start Date. onInit business rules will not work as per system design.

See Also

Keywords

INC10795692, Seniority Start Date, seniorityDate, Rehire, hire, onchange, onsave, oninit, business rule, default, change, how to, Seniority Start Date is being defaulted from rehire date, employee central, employment details, successfactors , KBA , LOD-SF-EC-EMP , Employment Information (Employment Details) , How To

Product

SAP SuccessFactors Employee Central 1611 ; SAP SuccessFactors Employee Central 1702 ; SAP SuccessFactors Employee Central 1705 ; SAP SuccessFactors Employee Central 1708