Symptom
When we perform a rehire, we notice that the field Seniority Start Date is automatically being populated with the Rehire date
Environment
Employee Central - Employment Information
Reproducing the Issue
1. Check the Seniority Start Date of a inactive employee
2. Rehire the inactive user
3. Observe that the seniority start date has changed to the rehire date
Cause
This is expected system behaviour
Resolution
For new hires, the seniority start date field will have the same date as the hire date
For rehires, the seniority start date will default from the rehire date due to the following:
A user cannot be rehired into the system unless they have been terminated. The system reads this as the user is terminated from the system and is no longer active
When rehiring the user, the system disregards the seniority that was built up in the previous employment and starts from scratch as of the rehire date
See Also
Keywords
Seniority Start Date seniorityDate Rehire , KBA , LOD-SF-EC-EMP , Employment Information (Employment Details) , Problem