Symptom
An business user opens a report for which there is an access context (for example, 1015 Employee, Territory, Account, Sales Data). Instead of seeing his own (and his employee's) data only, one of the 2 scenarios happens:
- The user sees all data.
- The user sees no data at all.
Environment
-
SAP Cloud for Customer
- SAP Business ByDesign
Reproducing the Issue
- Open the report from the assigned work center.
- Check the Access Context - it will be restricted.
- Click on Go.
Either you will see all the report data, or the report returns no results at all. For this user however, it is expected to show some specific (restricted) results.
Cause
See below for possible reasons:
A) There are no access restrictions maintained for the work center view(s) that this report is assigned to. The access context of the report can only work if there are also access restrictions on the respective work center views. If there are no restrictions, this will create a conflict.
B) The report is assigned to a work center for which there is a conflict in access contexts. Whenever such an assignment is done, the access restriction cannot be applied.
C) The access restrictions were maintained, but you maintained different restrictions for different work center views. For example, the report and the user are assigned to 2 work center views. On the user level, you have maintained different restrictions for these work center view, one is restricted on user's data and the other is restricted to the user's team. The report will use the wider restriction, i.e. it will show the data of the user's team.
D) Other where access context shows as Unrestricted.
Resolution
Scenario A)
- Go to the work center Application and User Management, view Business Users.
- Search for the respective user and click on Edit > Access Rights
- Go to the tab Access Restrictions
- Search for every work center view that the report is assigned to
- Under Read Access, maintain an access restriction.
This has to be done for all work center views that this report and this user are assigned to. If you are using business roles (C4C only), please maintain a restriction on the business role level.
Scenario B)
- Go to the work center Business Analytics, view Design Reports.
- Search for the report and click on Assign.
- From the Show dropdown, select Assigned (this will show all work centers that the report is assigned to).
- Check if there is a conflict with the access context of this work center view. If there is, the access restriction cannot work. You can unassign the report from this work center to avoid this.
Scenario C)
It is correct that if different restrictions are set, the wider restriction will apply to the report. Please make sure that the same restriction is set for each work center view that the report is assigned to. It is help to assign the report to as few work center views as possible. This way, you have less work center views where you need to align restrictions.
Scenario D)
Please unassign all Work Center Views and Business Roles (if any) of the report and reassign the same back again. This should regenerate the access context successfully.
See Also
2575041 - Conflict of Access Context During Report Assignment
2592130 - How to Set the Access Context of the Report
2742771 - Access Context in Joined Data Sources
Keywords
Access Context, context, report, restricted, not working, Business User , KBA , access context , access restrictions , report data , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To