SAP Knowledge Base Article - Public

2489387 - Approval Process is not Triggered for External Customer Invoice Request

Symptom

The approval for Customer Invoices is enabled in the system and also properly configured. However, when releasing a External Customer Invoice Request, the approval process is not triggered. The invoice is created and released directly.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing work center.
  2. Navigate to the Invoice Requests view.
  3. In the Show field select To Be Invoiced.
  4. Go to advanced search and select Invoice Type as External Customer Invoice Request.
  5. Click on the Go button.
  6. Select the External Customer Invoice Request XYZ. (XYZ refers to the External Customer Invoice Request ID)
  7. Click on Invoice and Release the invoice.

It is expected that the approval process is triggered and the invoice goes to approval process. However, this invoice is released directly with Approval Status as Not Started.

Cause

The approval process is not relevant for externally created invoice requests e.g. via the web service Manage Customer Invoice Request.

Please note that this also applies to Down Payment Requests created via the web service Manage Downpayment Customer Invoice Request.

Resolution

This the expected system behavior.

Keywords

external customer invoice request, approval, not triggered, invoice; down payment; down payment request; Manage Downpayment Customer Invoice Request; ManageDownPaymentCustomerInvoiceRequestIn, ManageCustomerInvoiceRequestIn , KBA , AP-CI-CI-GLO , Cross-Country Extensions , How To

Product

SAP Business ByDesign all versions