Symptom
You are unable to perform SEPA payments to Business Partners because of several error messages.
Reproducing the Issue
- Go to Payables work center.
- Go to Automatic Payments subview.
- Show Payments 'In Preparation' and find Payment ID XXX.(XXX represents the Payment ID)
- Open the Payment and click Edit.
- You receive the following error messages:'Missing entry in mandatory field Country of cust./suppl. XXX for SEPA Credit Transfer', 'Technical error FOP_PAYMED_PREP 024', 'Payment details not determined'.
Cause
The Business Partner data contains no country details which is a mandatory requirement for SEPA Transfers in SAP Business ByDesign.
Resolution
- Go to Business Partner Data work center.
- Navigate to Business Partners subview.
- Show all active Business Partners and find Business Partner XYZ. (XYZ represents the Business Partner ID)
- Open business partner XYZ and click View All.
- In General tab you see that no country is maintained under Main Address for Business Partner XYZ.
You have to maintain a country for your Business Partner to ensure that SEPA Payments are processed successfully.
Keywords
KBA , SRD-FIN-INV , Inventory , How To
Product
SAP Business ByDesign all versions