Symptom
There is a ticket within the system with a file attached that appears as message.rfc822. When you try to open this, the action is not allowed to you.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Navigate to WorkCentre
2. Go to Service
3. Click on Tickets
4. Open ticket id - 2911159
5. Go to the Interactions tab and open the e-mail.
6. On the e-mail, go to the Attachments tab.
7. You can see a file "noname.eml" (it may be .msg)
Cause
If you check the Allowed Mime Type list in Business Configuration, for the MIME Type Code 10022 the File Extension that is select as Default is the option msg.
Resolution
The option that will allow you to open this file is eml. So to select this option, please do the following manual steps:
- Go to Business Configuration -> Implementation Project -> open Activity List -> open Fine Tuning tab.
- Search for MIME and open the link.
- In the resulting screen, search for Mime Type: message/rfc822 or MIME Type Code 10022.
- Select the record and in the File Extension section, uncheck the default flag for msg.
- Select the record for "eml" and mark it as default.
See Also
Keywords
Email; Attachment types, MIME , KBA , LOD-CRM-SRP , Service Request Processing , How To