Symptom
Requesting a new advance, set the pay date field to a future date and this resets to to the request date after saving the information.
Reproducing the Issue
Request a new advance with a future date.
After saving this or approving the workflow. The date field will reset to the requested date. In the example below the field resets to the date of which it is requested.
Cause
This is how it's designed and is an expected behavior.
Resolution
Pay date field should not be enabled in UI. If enabled, this field always defaults the value from the “request date” field.
It's not possible to request advance for future date as per the current design.
See Also
ECT-75736
Keywords
Avandces Pay date field Reset Request Date Loan deudction , KBA , LOD-SF-EC-ADV , Advances , Problem