SAP Knowledge Base Article - Public

2491090 - Pay Date Field is Getting Reset to Request Date.

Symptom

Requesting a new advance, set the pay date field to a future date and this resets to to the request date after saving the information. 

Reproducing the Issue

Request a new advance with a future date. 

effecive date advance.png

After saving this or approving the workflow. The date field will reset to the requested date. In the example below the field resets to the date of which it is requested.

resets to request.png

Cause

This is how it's designed and is an expected behavior.

 

Resolution

Pay date field should not be enabled in UI. If enabled, this  field always defaults the value from the “request date” field.

It's not possible to request advance for future date as per the current design.

 

See Also

ECT-75736

Keywords

Avandces Pay date field Reset Request Date Loan deudction , KBA , LOD-SF-EC-ADV , Advances , Problem

Product

SAP SuccessFactors Employee Central 1611 ; SAP SuccessFactors Employee Central 1702 ; SAP SuccessFactors Employee Central 1705 ; SAP SuccessFactors Employee Central 1708