Symptom
You have set a ticket status as invisible in business configuration, but the advance filter in tickets view still displays it.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Configuration work center
- Select Open Activity List
- Search and open the activity Tickets for Customer Support.
- Select Maintain Status schemas.
- Uncheck the Status Visible checkbox for the status ABC (ABC represents the status name).
- Now, go to the Service workcenter.
- Go to the Tickets view.
- Open Advance Filter.
- The Status drop down has the status ABC.
As you have sent the status ABC as invisible, you expect that it does not display in the advance filer
Cause
Advanced filter shows all the values possible for the code list since it needs to be a superset. Any ticket that was set with status ABC in the past or future should be searchable. The business configuration setting is to control value shown in UI during editing of ticket instances.
Resolution
This is the current system behavior for SAP Cloud for Customer.
Keywords
Status ; Visible ; Invisible ; Active ; search , KBA , LOD-CRM-SRP , Service Request Processing , How To