SAP Knowledge Base Article - Public

2492791 - The Diagnostics Agent does not stay assigned in the Managed System Configuration

Symptom

During the Managed System Configuration, in the step 'Assign Diagnostics Agent', the Agent is correctly assigned. However, if you go back to the Assign Agent step, the Agent appears unassigned.

Environment

  • SAP Solution Manager 7.2

Reproducing the Issue

  1. Start the Managed System Configuration for a system
  2. Go to step ‘Assign Diagnostic Agent’
  3. Assign the Agent to the server
  4. Left the ‘Assign Diagnostic Agent’ screen
  5. Go back to the ‘Assign Diagnostic Agent’ step. The Agent will appear unassigned

Cause

Old entries in the Agent Administration page are causing this erroneous behavior.

Resolution

To fix the issue, follow the steps described in the topic "Automatically Remove the Zombie Entries" from the Wiki below:

https://help.sap.com/docs/SUPPORT_CONTENT/techops/3821554842.html?q=Automatically%20Remove%20the%20Zombie%20Entries

See Also

2385361 - How to connect Diagnostics Agent to Solution Manager 7.2 system

Keywords

connected, assigned, unassigned, disconnected, servername, missing, SMDAgent, solman_setup , KBA , SV-SMG-DIA , Diagnostics , Problem

Product

SAP Business ByDesign all versions