Symptom
When an admin changes the default filters for a tile based Dashboard, the changes don't reflect for certain users.
Environment
- SAP SuccessFactors HXM Suite
- Dashboards and Tiles
Reproducing the Issue
- Create a Tile based Dashboard and define default filters (Example: dataset).
- Share the Dashboard with users X, Y and Z.
- Login as user X and verify the Dashboard is available.
- Make changes to the default filters in the Dashboard
- Login as user X again.
- The filters haven’t changed.
- However, the Dashboard’s data has changed based on the new filter values for users Y and Z.
Cause
When an end user changes / sets the filter values in a Tile Based Dashboard, the system saves the user’s preferences for better user experience.
As a result, changes done to the default filters by the admin does not reflect for users who have already edited / set the filters in the Dashboard.
This behaviour is expected.
Resolution
Only changes done to the Dashboard's core will refresh the end user's preferences.
A possible solution that can be applied with this logic is:
- Edit the Tile based Dashboard.
- Add another tile or remove an existing tile.
- Save the Dashboard
- Revert the action performed in step 2.
- Save the Dashboard again.
- In case of Tiles end users should make necessary changes to the Filter or a new Tile should be created with and shared with the users.
Keywords
Tile, based, Dashboard, default, not saving, updating, user, admin, tile, dashboard, builder, save, enable, all, users, end , KBA , LOD-SF-ANA-DSH , YouCalc Dashboards and Tiles (Dashboards 2.0) , Problem