Symptom
We are getting an application error every time we try to edit a position. This only occurs when editing positions, not during the creation of a position
Environment
Employee Central – Position Management
Employee Central – MDF
Reproducing the Issue
- Admin Centre > Manage Positions
- Choose any Position > Edit any field
- Click Save
Cause
The MDF cache needs to be refreshed
Resolution
To clear the Metadata cache:
Admin Centre > OData API Metadata Refresh and Export > Refresh Metadata Cache
If this is not a visible option in admin centre, then you will need to permission it via RBP
The tool is found under the permission category Manage Integration Tools
Keywords
MDF, fingerprint=2f1c0d606756600bb9611d88ec77071edd1de9bf, Positions, Application Error, Metadata Cache, Refresh Metadata Cache, ObjectDefinition.getAssociationByNameOrId, getGOObjectDefitionForClass , KBA , LOD-SF-EC-POS , Position Management , LOD-SF-EC-MDF , MDF & EC2MDF Migration , Problem