Symptom
You want to maintain a template for the Customer Invoice / Credit Memo under an Account, however you find the Template field to be grayed out.
Reproducing the Issue
- Go to the Account Management work center.
- Select the Accounts view.
- Search for the Account ABC (ABC represents the ID of the Account).
- Click the Edit button and select the General option.
- Navigate to the Collaboration subtab, under the Communication tab.
- Select the Customer Invoice / Credit Memo line.
- The Template field is grayed out/inactive.
Cause
The field ‘Template’ for Customer Invoice / Credit Memo under account level is grayed out or inactive by default and this is the expected system behavior.
For the Customer Invoice / Credit Memo, the system will first use the Invoicing Unit to determine the form selection, and if the Invoicing Unit cannot be found, it will use the Seller Party.
Thus the form template selection does not depend on the Account, but on the rules that are defined in the ‘Form Template Selection’ subview under the Application and User Management work center.
Resolution
This is the expected system behavior.
Manually change the rules under the ‘Form Template Selection’.
Keywords
Template; Customer Invoice; Credit Memo; Account; , KBA , SRD-CRM-ACC , Account Management , How To