Symptom
You have created an Invoice document that contains an item which is a Product Specification, however, the Product Specification ID is not showing in the item.
Reproducing the Issue
1. Go to the Customer Invoicing work center.
2. Go to the Invoice Documents view.
3. Search for the Invoice XYZ (XYZ represents the ID of the document).
4. Click on the Edit button.
5. Scroll down and the Product Specification ID is not displayed in the Customer Invoice, although the ID is displayed in another document such as, e.g. Delivery note.
Cause
Currently, the Product Specification and Identified Stock ID is only shown in the Invoice, if it is an Over-The-Counter scenario, as the Product Specification is determine from the Identified Stock ID when creating document through the Over-The-Counter.
For any other scenario which is not the Over-The-Counter, we do not support the Product Specification and Identified Stock ID to be stored in the Invoice Request.
In regards to your documents, an Outbound Delivery Invoice Request was created, which does not carry the Product Specification and Identified Stock ID.
Resolution
This is a system behavior.
Keywords
KBA , customer invoicing , product specification id not showing , AP-CI-CI , Customer Invoice , How To