Symptom
When creating a Sales Order or Manual Customer Invoice in the system, the Payment Method field is not displaying any information.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the New Sales Order from the Common Tasks.
- Enter the Account ABC (ABC represents the account ID).
- Enter Payment Terms XYZ (XYZ represents the type of Payment).
- Select the Payment Method in the drop-down list.
The message "No Items Found" is displayed.
Cause
In order for a Payment Method to be displayed for the Sales Orders or Manual Invoice Requests in the system, it is required to scope a Payment Methods question which is found under the Business Configuration.
Resolution
To enable the Direct Debit option, follow the steps below.
- Go to the Business Configuration work center.
- Select the Implementation Projects view.
- Select the project line.
- Click on the Edit Project Scope button.
- Navigate to the 4th option (Questions tab).
- Expand Cash Flow Management.
- Expand Payment and Liquidity Management.
- Select the Payment Methods option.
- Navigate to the Incoming Payments ground. For Direct Debit, find the question "Do you want to use direct debit to receive payments from your customers?"
- Mark the check box under the In Scope, and Confirm the changes.
- Open the relevant account master data.
- Go to the Financial Data tab, add the Direct Debit in payment method and maintain the Bank Account or maintain the SEPA Mandate details.
Once you follow these steps, you should be able to see Direct Debit in the drop-down list when creating new sales orders or new manual invoice requests.
To enable the Credit Cards, you will need to contact SAP support by creating a new case. Please see the help center document: Customer Payments by Credit Card
See Also
Keywords
sales order, payment method, credit card, business configuration, not available, not displayed , KBA , AP-SLO , Sales Order Processing , How To
SAP Knowledge Base Article - Public