Symptom
When you delete a Category from Activity Activities, documents that use the Category remain with the technical codes.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Configuration work center.
- Go to Activity Activities.
- Click on Assignment of Categories.
- Delete a row from Available Categories for Activity XYZ list. (XYZ represents the Available Activity Type).
- Save the settings.
- Open any document which uses the category.
Document remains with the Technical Code.
You expect the Category to be blank, since you deleted it.
Cause
As per SAP Hybris Cloud for Customer Administrator Guide, navigate to section:
- SAP Hybris Cloud for Sales.
- Sales features.
- Leads.
- Maintaining categories.
If you delete category entries that are used in documents, the technical codes stay in the documents and only the code descriptions are removed.
Resolution
This is the expected system behavior.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
KBA , LOD-CRM-EMP , Employee , How To