SAP Knowledge Base Article - Public

2494897 - After Deleting Categories, Sales Documents Remain With Technical Codes

Symptom

When you delete a Category from Activity Activities, documents that use the Category remain with the technical codes.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Business Configuration work center.
  2. Go to Activity Activities.
  3. Click on Assignment of Categories.
  4. Delete a row from Available Categories for Activity XYZ list. (XYZ represents the Available Activity Type).
  5. Save the settings.
  6. Open any document which uses the category.

Document remains with the Technical Code.

You expect the Category to be blank, since you deleted it.

Cause

As per SAP Hybris Cloud for Customer Administrator Guide, navigate to section:

  1. SAP Hybris Cloud for Sales.
  2. Sales features.
  3. Leads.
  4. Maintaining categories.

If you delete category entries that are used in documents, the technical codes stay in the documents and only the code descriptions are removed.

Resolution

This is the expected system behavior.

If you need this functionality urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.

You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html . You can contact Cloud Service Center as follows:

An alternative option may be to check the SAP Business ByDesign Influence Forum to submit an idea: https://ideas.sap.com/SAPCloudforCustomer

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711