Symptom
The Employee Central standard report templates 'Annual Compensation History' and 'Annual Compensation Overview' do not fetch data inspite of relevant data presence in the instance.
Environment
SuccessFactors Advanced Reporting
Reproducing the Issue
- Download the latest version of the reports from the SAP help portal.
- Upload them to the instance and validate them (no validation errors).
- Run the reports. No data is fetched.
Cause
The reports use the 'Pay Group (Label)' from the 'Compensation Emp Comp Info T' as a key field.
This is defined in the data model by default and hence is always shown.
However, if the field has not been configured in the instance, it will be grayed out and as a result reports built based on this field will not fetch data.
2495825 - Pay Grade and Pay Group fields are grayed out in Advanced Reporting.
Resolution
The 'Pay Group (Label)' field has to be removed from the report and it can be done through the following steps:
- Expand the report and edit one of the pages by clicking on it.
- Edit the query once inside the page.
This will lead you to the pivot report. - Once in the pivot designer, click the edit icon and access the underlying list query.
- In the query, expand the 'Compensation Emp Comp Info T' table.
Unselect the 'Pay group (Label)' field and select a field relevant to the requirement / instance (Ex: Comp Info ID) - Save changes and exit from the list query, then the Pivot report and then the report page.
Note:
- The fix will have to be applied to all the report pages individually.
- Uploading the standard reports again for some reason, will overwrite the modified version and the fix will ahve to be applied again.
Keywords
Annual Compensation History
Annual Compensation Overview , KBA , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , Problem