SAP Knowledge Base Article - Public

2495900 - "The import header is invalid" error when importing picklists

Symptom

Customer is unable to import non-English (Chinese, Japanese...) picklists. Every time when trying to import the picklist file the following error message appears:

"The import header is invalid. Import process is stopped. No locales specified in the header."

Error Message capture.png

Environment

SuccessFactors HXM Suite

Reproducing the Issue

  1. Login to system, navigate by Admin Center>Go to Picklists management> Import picklists;
    1. All picklists new? NO.
    2. Character encoding selected Simplified Chinese 2312.
  2. Imported File header is configured like:
    1. picklistImportHeader.png
  3. Read error message as:
    1. "The import header is invalid. Import process is stopped. No locales specified in the header."

Cause

In Picklist import file, locale en_US is required (must-have column), which is by design.

Resolution

In Picklist import file, locale en_US is required. Hence to aviod such error, please add column en_US before zh_CN and try importing again.

picklistImportHeader_updated.png

Note:

The picklist file you download from the system is in a CSV (Comma Separated Values) format. This is a very popular format for moving data between applications. It is important that you preserve this format. It is recommended that you use a text editor that supports UTF-8 formats to edit the file. By default, the file opens in a spreadsheet editor. (Getting Familiar with the Picklist File)

See Also

 What's New in Implementing Picklists

Keywords

import header, invalid, stopped, No locales specified in the header, en_US, import picklists , KBA , LOD-SF-PLT-PCK , Picklist Management Issue , Problem

Product

SAP SuccessFactors HCM Suite all versions