SAP Knowledge Base Article - Public

2496148 - Unable to schedule reports in Report Center

Symptom

You are unable to schedule reports in Report Center as the option is greyed out although all RBP permissions are applied.
When you hover over the option a message is displayed:

'Schedule cannot be created as it requires Generic Object Support to be enabled. Please contact your administrator.'

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HCM Suite
    • Report Centre

Reproducing the Issue

  1. Reporting then Report Center
  2. From the Action Menu the New Schedule option is greyed out and are unable to schedule a report

    Report Canvas New Schedule error.png

Cause

For Scheduling functionality to be used, in report center, we mandate that we have Enable Generic Objects — requires “Enable the Attachment Manager” enabled from provisioning.

Resolution

Please search for Enable Generic Objects — requires “Enable the Attachment Manager” in company settings in provisioning and ensure this is enabled.
enable Generic object v.png

Once the feature is enabled from provisioning the New Schedule option is available and can be used for Report scheduling.

Keywords

Report, Centre, schedule, unable, greyed, error, missing, Schedule a Report, reports , KBA , LOD-SF-ANA-RCT , Report Centre , LOD-SF-ANA , Analytics & Reporting (Ad Hoc, YouCalc, ORD) , Problem

Product

SAP SuccessFactors HCM Suite all versions